Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
[gelöst] irmplircd konfigurieren
#1
Hi,

ich kämpfe hier mit diversen Fernbedienungen im Zusammenspiel mit irmplircd (IRMP / STM32). Anfangs dachte ich, es liegt nur an Fernbedienungen mit dem NEC Protokoll aber meine Harmony 300 mit KLS Profil läuft mit IRMP auch nicht sooo toll. Ich habe versucht an den irmplircd Parametern in der easyvdr-irmplircd.conf etwas zu konfigurieren aber das führt nicht zum Erfolg.

Wie kann man denn irmplircd konfigurieren? Vor lauter Verzweifelung bin ich mit meinem Test VDR mal fremdgegangen und habe yavdr 0.6x installiert  Angel Angel Angel Die Fernbedienungen funktionieren nach einspielen der Map Datei mit yavdr ohne Probleme. Ich finde in den Konfigurationsdateien dort keine ungewöhnlichen Parameter...

Danke und Gruß

Obelix
Zitieren
#2
Hi Obelix
Ich nutze auch eine Harmony 300 in EasyVDR 3.5
Aber mit MS_MCE Code.
Evtl. kommt es auch darauf an was für ein TSOP verbaut ist RC5 Modelle am besten mit einen 38kHz Tsop
und RC6 Modelle mit 36kHz. Es gibt auch Tsop,s mit 36,7 kHz die gehen dann auch fuer beide Codes.

Im EasyVDR Setup Tool OSD gibt es ein Menupunkt Experimental
Dazu auf der Startseite des Toolmenu fuer easyVDR etwas runter scrollen auf Experimental
Dort gibt es einen IRMP Keymap Builder
Damit kannst Du dir eine neue keymap erstellen..

Vllt noch interessant dieser Thread: http://www.easy-vdr.de/thread-18225.html
Beitrag #73

Gruß Oberlooser
Test-VDR : Digitainer I Gehäuse - ASRock A75M-HVS Board - AMD A4 3300 FM1 CPU - 2x1GB DDR3 RAM - MSI GT 710 PCI-e HDMI - TT S2 1600 PCI + Skystar 2.6D - 1TB W.D. Green HDD - Sony Optiarc DVD - CIR Nuvoton mit SMK RC6 MCE 50GB Fernbedienung - EasyVDR 3.5-64 Stable  - Softhddevice mit Pulseaudio und estuary4vdr OSD - Kodi 17.6 Final mit Confluence Skin
VDR-Client,s : Media MVP Scart, VIP BOX 1903, 1910 , EasyStream 0.6-18 für WIN 10, Raspberry PI 3 mit OpenElec 7.01 und TotalControl FB Code 0104 Lirc an Tsop 31238
Zitieren
#3
Hi Oberlooser,

nein, keymap ist es nicht. Den TSOP kann man ausschließen, denn sonst würde es ja mit yaVDR nicht funktionieren. Einzigen Unterschied den ich gefunden habe, in easyVDR wird irmplircd mit der Option -r 150 aufgerufen. Leider keine Änderung, wenn ich die Option weg lasse.
Zitieren
#4
Was funktioniert denn nicht ???
Produktiv-VDR:
Board GA H77-DS3H, Intel Intel® Core™ i5-3470, Cine S2 DVB, WD 3TB Green, WDC WD20EARS-00J  2TB, Geforce 750Ti oder Intel HD
Easyvdr 3.0
Zitieren
#5
(10.02.2018, 22:03)Bleifuss2 schrieb: Was funktioniert denn nicht ???


Bei den Fernbedienungen mit dem NEC Protokoll funktionieren lediglich die Pfeiltasten vom Steuerkreuz, Leiser / Lauter und Kanal + / Kanal -. Mit funktionieren meine ich, die Tasten, die an den VDR weitergeleitet werden. irw reagiert auf alle Tasten.
Zitieren
#6
Achja, die remote.conf passt-
Zitieren
#7
Zeit IRW die Namen von deiner map Datei an oder nummern?
Produktiv-VDR:
Board GA H77-DS3H, Intel Intel® Core™ i5-3470, Cine S2 DVB, WD 3TB Green, WDC WD20EARS-00J  2TB, Geforce 750Ti oder Intel HD
Easyvdr 3.0
Zitieren
#8
(10.02.2018, 22:30)Bleifuss2 schrieb: Zeit IRW die Namen von deiner map Datei an oder nummern?

Code:
02eb14004200 9 KEY_MENU IRMP
02eb14004200 a KEY_MENU IRMP
02eb14004200 b KEY_MENU IRMP
02eb14004200 c KEY_MENU IRMP
02eb14004100 d KEY_HOME IRMP
02eb14004100 e KEY_HOME IRMP
02eb14004100 f KEY_HOME IRMP
02eb14004100 10 KEY_HOME IRMP
02eb14000100 11 KEY_POWER IRMP
02eb14000100 12 KEY_POWER IRMP
02eb14000100 13 KEY_POWER IRMP
02eb14000100 14 KEY_POWER IRMP
02eb14000100 15 KEY_POWER IRMP
02eb14004200 16 KEY_MENU IRMP
02eb14004200 17 KEY_MENU IRMP
02eb14004300 18 KEY_SUBTITLE IRMP
02eb14004400 19 KEY_TEXT IRMP
02eb14004500 1a KEY_DELETE IRMP
02eb14000b00 1b KEY_AV IRMP
02eb14000c00 1c KEY_0 IRMP
02eb14000c00 1d KEY_0 IRMP
02eb14000d00 1e KEY_PREVIOUS IRMP
02eb14000d00 1f KEY_PREVIOUS IRMP
02eb14000a00 0 KEY_9 IRMP
02eb14000c00 1 KEY_0 IRMP
02eb14000900 2 KEY_8 IRMP
02eb14000900 3 KEY_8 IRMP
02eb14000600 4 KEY_5 IRMP
02eb14000800 5 KEY_7 IRMP
02eb14000a00 0 KEY_9 IRMP
Zitieren
#9
Wenn ich eine Taste die nicht an den VDR durchgereicht wird schnell genug hintereinander drücke, dann geht es irgendwann.
Zitieren
#10
(10.02.2018, 22:39)obelix schrieb: Wenn ich eine Taste die nicht an den VDR durchgereicht wird schnell genug hintereinander drücke, dann geht es irgendwann.

Bei der Menu Taste geht irgendwann der PChanger auf. 

Confused
Zitieren
#11
Hi Obelix
(10.02.2018, 22:54)obelix schrieb: Bei der Menu Taste geht irgendwann der PChanger auf. 
Das ist korrekt, die Menü Taste ist im pchanger default, drückst du sie etwas länger wird pchanger aufgerufen.


Gruß Aaron

Gesendet von meinem S7Edge mit Tapatalk
Mediacenter
easyVDR3.5(4.x.x 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel® G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

Zitieren
#12
(10.02.2018, 22:39)obelix schrieb: Wenn ich eine Taste die nicht an den VDR durchgereicht wird schnell genug hintereinander drücke, dann geht es irgendwann.
Du sagst also, irw erkennt die Taste sofort und vdr erst, wenn du sie mehrfach drückst?

Du kannst ja mal folgendes probieren:

sudo stopvdr

Dann unter /var/lib/vdr/ die remote.conf irgendwo hinsichern und in dem Verzeichnis löschen.

sudo startvdr

Warten bis das Frontend mit einem schwarzen Bild kommt, irgendeine Taste der Fernbedienung drücken und gedrückt halten. Irgendwann sollte das osd mit dem Assistenten starten. Dann mal versuchen ob du alle Tasten angelernt bekommst.

Gruß Aaron

Gesendet von meinem S7Edge mit Tapatalk
Mediacenter
easyVDR3.5(4.x.x 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel® G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

Zitieren
#13
Hi Aaron,
(11.02.2018, 07:17)gb schrieb: Hi Obelix
(10.02.2018, 22:54)obelix schrieb: Bei der Menu Taste geht irgendwann der PChanger auf. 
Das ist korrekt, die Menü Taste ist im pchanger default, drückst du sie etwas länger wird pchanger aufgerufen.


Gruß Aaron

Gesendet von meinem S7Edge mit Tapatalk
ja das ist bewusst. War anders gemeint.
Zitieren
#14
(11.02.2018, 07:31)gb schrieb:
(10.02.2018, 22:39)obelix schrieb: Wenn ich eine Taste die nicht an den VDR durchgereicht wird schnell genug hintereinander drücke, dann geht es irgendwann.
Du sagst also, irw erkennt die Taste sofort und vdr erst, wenn du sie mehrfach drückst?

Du kannst ja mal folgendes probieren:

sudo stopvdr

Dann unter /var/lib/vdr/ die remote.conf irgendwo hinsichern und in dem Verzeichnis löschen.

sudo startvdr

Warten bis das Frontend mit einem schwarzen Bild kommt, irgendeine Taste der Fernbedienung drücken und gedrückt halten. Irgendwann sollte das osd mit dem Assistenten starten. Dann mal versuchen ob du alle Tasten angelernt bekommst.

Gruß Aaron

Gesendet von meinem S7Edge mit Tapatalk

Kann ich gleich gerne mal testen aber ich denke nicht das es daran liegt. irw reagiert ohne Verzögerung und auf alle Tasten. Wie sieht es mit inputlirc aus? Gibt es da eventuell etwas zu parametrisieren?

Gruß
Obelix
Zitieren
#15
Habe die remote.conf mal gelöscht und den Anlerndialog durchgeführt. Die FB reagiert eine gewisse Zeit gut aber dann reagiert sie nicht mehr bzw. erst durch mehrfaches drücken passiert etwas. Das habe ich jetzt zweimal gemacht und das Problem tritt an unterschiedlichen stellen auf.
Zitieren
#16
Woran erkennt man den Unterschied zwischen 3.0 und 3.5 nochmal?
Zitieren
#17
(11.02.2018, 09:01)obelix schrieb: Habe die remote.conf mal gelöscht und den Anlerndialog durchgeführt. Die FB reagiert eine gewisse Zeit gut aber dann reagiert sie nicht mehr bzw. erst durch mehrfaches drücken passiert etwas. Das habe ich jetzt zweimal gemacht und das Problem tritt an unterschiedlichen stellen auf.
Ehrlich, das ist mir eine Nummer zu hoch. Es gehen alle Tasten tadellos und irgendwann aus heiterem Himmel quittiert einfach Dienst?

Was sagt denn das syslog in dem Zeitfenster, gibt's da Fehlermeldungen?

Gruß Aaron
Mediacenter
easyVDR3.5(4.x.x 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel® G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

Zitieren
#18
(11.02.2018, 09:04)obelix schrieb: Woran erkennt man den Unterschied zwischen 3.0 und 3.5 nochmal?
Prüfe einfach gegen ffmpeg3
Code:
apt-cache policy ffmpeg3
Hast du da eine positive Ausgabe, ist es easyvdr3.5

Beispiel:
Zitat:root@easyVDRWohnzimmer:/etc/apt# apt-cache policy ffmpeg3
ffmpeg3:
  Installiert:           3.3.0-0easyVDR2~trusty
  Installationskandidat: 3.3.0-0easyVDR2~trusty
  Versionstabelle:
 *** 3.3.0-0easyVDR2~trusty 0
       1003 http://ppa.launchpad.net/easyvdr-team/hevc-base/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status
Mediacenter
easyVDR3.5(4.x.x 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel® G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

Zitieren
#19
(11.02.2018, 09:06)gb schrieb:
(11.02.2018, 09:01)obelix schrieb: Habe die remote.conf mal gelöscht und den Anlerndialog durchgeführt. Die FB reagiert eine gewisse Zeit gut aber dann reagiert sie nicht mehr bzw. erst durch mehrfaches drücken passiert etwas. Das habe ich jetzt zweimal gemacht und das Problem tritt an unterschiedlichen stellen auf.
Ehrlich, das ist mir eine Nummer zu hoch. Es gehen alle Tasten tadellos und irgendwann aus heiterem Himmel quittiert einfach Dienst?

Was sagt denn das syslog in dem Zeitfenster, gibt's da Fehlermeldungen?

Gruß Aaron

Ich teste gerade mal eine ältere Version. Problem mit dem syslog ist, dass dieser mit den Meldungen

Zitat:Feb 11 08:56:09 optiplex-390 vdr: video: display buffer empty, duping frame (12096/0) 0
Feb 11 08:56:09 optiplex-390 vdr: video: display buffer empty, duping frame (12097/0) 0
Feb 11 08:56:09 optiplex-390 vdr: video: display buffer empty, duping frame (12098/0) 0
Feb 11 08:56:09 optiplex-390 vdr: video: display buffer empty, duping frame (12099/0) 0
Feb 11 08:56:09 optiplex-390 vdr: video: display buffer empty, duping frame (12100/0) 0
Feb 11 08:56:09 optiplex-390 vdr: video: display buffer empty, duping frame (12101/0) 0
Feb 11 08:56:09 optiplex-390 vdr: video: display buffer empty, duping frame (12102/0) 0
Feb 11 08:56:09 optiplex-390 vdr: video: display buffer empty, duping frame (12103/0) 0
Feb 11 08:56:09 optiplex-390 vdr: video: display buffer empty, duping frame (12104/0) 0
Feb 11 08:56:09 optiplex-390 vdr: video: display buffer empty, duping frame (12105/0) 0
Feb 11 08:56:09 optiplex-390 vdr: video: display buffer empty, duping frame (12106/0) 0

geflutet wird, bis ich einmal eine Aufzeichnung gestartet und wieder beendet habe. Auch das OSD ist anfangs nur 4:3. Ist ein Intel System und da es mein "Test VDR" ist, hat es mich nicht sooo gestört.
Zitieren
#20
(11.02.2018, 09:13)gb schrieb:
(11.02.2018, 09:04)obelix schrieb: Woran erkennt man den Unterschied zwischen 3.0 und 3.5 nochmal?
Prüfe einfach gegen ffmpeg3
Code:
apt-cache policy ffmpeg3
Hast du da eine positive Ausgabe, ist es easyvdr3.5

Beispiel:
Zitat:root@easyVDRWohnzimmer:/etc/apt# apt-cache policy ffmpeg3
ffmpeg3:
  Installiert:           3.3.0-0easyVDR2~trusty
  Installationskandidat: 3.3.0-0easyVDR2~trusty
  Versionstabelle:
 *** 3.3.0-0easyVDR2~trusty 0
       1003 http://ppa.launchpad.net/easyvdr-team/hevc-base/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status

Ok, wenn ich nachher wieder zurück installiere. Habe hier mehrere USB Sticks und ich weiß gerade nicht mehr welche Version ich hier wo drauf habe  Angel Wink
Zitieren
#21
Du hast also kein aktives DVB-Device mit TV-Empfang an dem System?
Mediacenter
easyVDR3.5(4.x.x 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel® G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

Zitieren
#22
(11.02.2018, 09:17)gb schrieb: Du hast also kein aktives DVB-Device mit TV-Empfang an dem System?

Doch aber nicht immer angeschlossen. Ist wie gesagt Test Hardware.
Zitieren
#23
So, Version 2.5, 3.0 und 3.5 getestet. Alle identisch.
Zitieren
#24
Hi,
die sind ja alle auf trusty Basis...

MfG,
Stefan.
Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, als Tuner FF-SD C-2300, nvidia Slim-GT218 512MB PCIe x1 v3.-64 stable
VDR2 in Rente
VDR3 in Rente
VDR4: MSI G31M2 v2, Intel E5200, 6" t6963c gLCD, 2GB, WD 2TB+3TB, 2x TT3200 + ASUS GT730-SL-2GD3-BRK + mod. Digitainergeh. v3-64
VDR5: GIGABYTE GA-G31M-S2L + Intel E5200 + GT220 + Zalman ZNF 100 Passivkühler + 2GB + t6963c gLCD + Satelco DVB-C+CI + Sundtek DVB-C/T v2010+mod. Digitainergeh. v1
VDR6: MSI MS-7236, Intel E2140, GT630 passiv, 2GB, 750GB, t6963c gLCD, 2x TT3200 v2.5-64
Hilfe gefällig? Dann brauchen wir ein easyInfo aus easyPortal!
Zitieren
#25
Ähh...
(11.02.2018, 11:39)SurfaceCleanerZ schrieb: die sind ja alle auf trusty Basis...
..und das heißt was?
Ist da ein Bug bekannt?

Erleuchte uns dochmal.

Gruß Aaron

Gesendet von meinem S7Edge mit Tapatalk
Mediacenter
easyVDR3.5(4.x.x 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel® G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste